Results 1 to 9 of 9
  1. #1

    • Avid Photographer!
    • Offline

    Join Date
    Mar 2010
    Location
    Sillicon Valley, CA
    Posts
    224

    Broken Picture Posting?

    I'm trying to start posting my pictures from my June Disneyland trip & for some reason, the code comes out all funny. To give people an option of getting high-res pictures without forcing everyone to download them all first I link to the smaller sizes on flickr, and link the picture itself back to it's flickr photo page.

    Here's an example of the code I would use (Brackets have been replaced with greater & less than signs because CODE still processes BBCode):

    Code:
    <url="http://www.flickr.com/photos/mrweb/4915119619/"><img>http://farm5.static.fliackr.com/4097/4915119619_0d6d244582.jpg</img></url>


    Which looks like this when processed:

    The other thing I tried was just dumping the native BBCode generated by Flickr, which looks like this when rendered:


    Driving Down | Flickr - Photo Sharing! by MistrWebmastr, on Flickr

    Can anyone explain what's going on? I like to link the pictures themselves to preserve space on the thread which will already be HUGE

    Thanks!
    Andrew
    Last edited by Monorail Man; 08-23-2010 at 12:42 AM. Reason: Updated to reflect proper code usage.

  2. #2

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,433

    Re: Broken Picture Posting?

    you want




    just quote my post to see the format... but it's basically {url="pagelink"}{img}imagelink{/img}{/url}

    replace curly brackets with brackets
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

  3. #3

    • Avid Photographer!
    • Offline

    Join Date
    Mar 2010
    Location
    Sillicon Valley, CA
    Posts
    224

    Re: Broken Picture Posting?

    Oh interesting. Apparently {url} and {URL} are different. I need to make sure the code is in all caps. That's the problem I'm having!

    Thanks!

  4. #4

    • Avid Photographer!
    • Offline

    Join Date
    Mar 2010
    Location
    Sillicon Valley, CA
    Posts
    224

    Re: Broken Picture Posting?

    Yea, there's something seriously wrong here. I have my picture thread all typed up in notepad, properly coded with {URL="."}{IMG}.{/IMG}{/URL} and for whatever reason, when I go to preview it, it formats it like {URL}."}{IMG}.{/IM{/URL}

    Though I go to test it, and it works for the preview, yet broke once I posted it - again! This is frustrating, and I really don't want my thread to get stale & not be able to actually post the pictures for it.

  5. #5

    • Avid Photographer!
    • Offline

    Join Date
    Mar 2010
    Location
    Sillicon Valley, CA
    Posts
    224

    Re: Broken Picture Posting?

    It looks like it may have been due to Google Docs auto replacing " with typographers quotes. (the ones with the curls on them) They look the same, but it always breaks coding stuff. I should have caught that. I only found out when I went and threw the code into VIM in an SSH terminal and saw all these random periods (what replaced the typographers quote marks) and once I replaced them, it seemed to go fine!

    For those of you who are using Word/Google Docs/etc - make sure you paste through notepad & REPLACE QUOTE MARKINGS! Don't make my mistake!

    EDIT: However, this still doesn't explain why a direct copy-paste from Flickr wouldn't work - or is that because it's formatted in {URL=.}

  6. #6

    • MiceChat Administrator
    • Following The Optimist
    • Offline

    Join Date
    Jan 2005
    Location
    Irvine, CA
    Posts
    4,616

    Re: Broken Picture Posting?

    Hi MistrWebmastr,

    I've got a quick update about this. Apparently, sometime in the last 24 hours, Flickr changed the way that it handles URLs. We have auto-embedding for most web videos, so it would automatically change the URL to a video. Well, Flickr's server-side reporting changed, so all photos we're being flagged as 'media', instead of just videos.

    I've made the change, so img-tagged postings should work.

    Also, URLs work with or without the quote marks.

    -Monorail Man
    Last edited by Monorail Man; 08-23-2010 at 12:43 AM.

  7. #7

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,433

    Re: Broken Picture Posting?

    what you saw with word is what is referred to often as 'smart quotes' which is where an editor automatically can change the default straight quotes to the curl'd ones. The characters are actually different, so when you copy/paste... odd behaviors are common. You can avoid it by forcing the font or saving as txt first. I think there is a Word setting for it too. But the best suggestion is.. never use a Word Processor as a text editor I prefer Notepad++ on Windows (but I do a lot of coding type stuff too)

    but as MM has chimed in, seems like a good portion of the problem was auto-rewriting that was happening by the forum.
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

  8. #8

    •   
      MiceChat Moderator
    • Mickey and 'Key
    • Offline

    Join Date
    Apr 2005
    Location
    All smiles at the DL!
    Posts
    20,517
    Blog Entries
    4

    Re: Broken Picture Posting?

    Thanks for fixing it, MM. What flickr is now doing with the photos hosted on its site is frustrating a lot of us paying users!!
    Good morning, son
    In twenty years from now
    Maybe we'll both sit down and have a few beers
    And I can tell you 'bout today
    And how I picked you up and everything changed
    It was pain
    Sunny days and rain
    I knew you'd feel the same things...





  9. #9

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,433

    Re: Broken Picture Posting?

    FWIW... I hate the new video embedding.. its like watching a postage stamp
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

Similar Threads

  1. help with posting a picture
    By sabres8691 in forum The Forums
    Replies: 9
    Last Post: 12-25-2007, 12:22 PM
  2. broken luggage - help!
    By fairygoodmother in forum MiceChat Main Lounge
    Replies: 6
    Last Post: 03-19-2007, 09:50 PM
  3. Anybody With A Broken Leg?
    By TikiRoomLiz in forum MiceChat Main Lounge
    Replies: 7
    Last Post: 10-27-2006, 07:48 PM
  4. Broken toe..
    By EagleWings in forum MiceChat Main Lounge
    Replies: 22
    Last Post: 09-25-2006, 11:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •