Results 1 to 11 of 11
  1. #1

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,667

    Bugs with new thread renaming SEO system?

    I think I've found some problems with the recent site changes for the SEO mod.

    I was using the 'find all posts by <user>' link in a profile page which lists all posts by a user. Example, here's one with my history

    http://www.micechat.com/forums/searc...d=945388&pp=25

    If you look at the actual links in the pages, they are incorrect.

    The thread title in bold is supposed to link to the actual thread - instead the link is only to the forum containing the thread. This makes that link pretty useless.

    The link to the post's title, is supposed to take you to the exact post, this link looks correct, example
    http://www.micechat.com/forums/conte...ml#post2176275

    But instead of taking you to the specific post, it only takes you to the first post of the thread. Wondering if the rewrite stuff is working properly for this. This too makes the links very useless when trying to find a post in a large thread.

    This combined with my inability to find a post by search (listed in a separate thread) made it pretty tough to find a specific post. I understand these may be changes to help with the scale of the site, but the page as is makes finding posts very difficult!

    Any help appreciated! thx
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

  2. #2

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,667

    Re: Bugs with new thread renaming SEO system?

    bump-dity bump. Monorail Man? Input?
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

  3. #3

    • MiceChat Administrator
    • Following The Optimist
    • Offline

    Join Date
    Jan 2005
    Location
    Irvine, CA
    Posts
    4,617

    Re: Bugs with new thread renaming SEO system?

    If I do it, it drops to the post in the text just fine.

    http://www.micechat.com/forums/conte...ml#post2176275

    And yes, this is a correct link, it drops me to this post:

    Quote Originally Posted by flynnibus View Post
    In my travels.. MOST still charge for internet. Free internet is considered a 'perk'.
    [...]
    However, this doesn't work in Safari, due to Apple's bug when parsing anchors that uses mod_rewrite. This is the same issue as the thread below. When the URL is rewritten to Safari, it drops any sort of "#" on the URL. It's a confirmed bug in Safari, however, it's been this way for a couple of versions. It looks as if all Safari users will have to use the previous PHP page (un SEOed system).
    -Monorail Man

  4. #4

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,667

    Re: Bugs with new thread renaming SEO system?

    I'm FF 2.0.0.7 on WinXP - I don't use safari

    If I try the link you posted in IE7, I get taken to the first page of the thread and the address bar shows the URL without the #whatever portion.

    In FF 2.0.0.7, the address bar does not change, but still only takes me to the first page.

    Also, what about the thread links being incorrect in the 'find posts..' page. All the thread links (not the post links) only point to the forum, not the thread
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

  5. #5

    • MiceChat Administrator
    • Following The Optimist
    • Offline

    Join Date
    Jan 2005
    Location
    Irvine, CA
    Posts
    4,617

    Re: Bugs with new thread renaming SEO system?

    Try it now. I've tweaked a setting.

    It's worked for me in FF and IE and Safari.

    The Search Results have been fixed.
    -Monorail Man

  6. #6

    • Winter in Oceanside...
    • Offline

    Join Date
    Oct 2005
    Posts
    6,747

    Re: Bugs with new thread renaming SEO system?

    I just tried a basic search in the "Search Forums" cell. It did not work (and I searched a title that I started just so I could use something that I know is there).

    BTW, I am using Firefox on a PC.

  7. #7

    • MiceChat Administrator
    • Following The Optimist
    • Offline

    Join Date
    Jan 2005
    Location
    Irvine, CA
    Posts
    4,617

    Re: Bugs with new thread renaming SEO system?

    Quote Originally Posted by PrincessY View Post
    (and I searched a title that I started just so I could use something that I know is there).
    How soon did you start it? It can take several hours before the posts are cataloged in the fulltext search.
    -Monorail Man

  8. #8

    • Winter in Oceanside...
    • Offline

    Join Date
    Oct 2005
    Posts
    6,747

    Re: Bugs with new thread renaming SEO system?

    It is at least 2 weeks old. Is there a time limit? I was under the impression that "Search" would help us research old topics.

  9. #9

    • MiceChat Administrator
    • Following The Optimist
    • Offline

    Join Date
    Jan 2005
    Location
    Irvine, CA
    Posts
    4,617

    Re: Bugs with new thread renaming SEO system?

    Quote Originally Posted by PrincessY View Post
    It is at least 2 weeks old. Is there a time limit? I was under the impression that "Search" would help us research old topics.
    Nevermind. Search in the Quick Box works now.
    -Monorail Man

  10. #10

    • Winter in Oceanside...
    • Offline

    Join Date
    Oct 2005
    Posts
    6,747

    Re: Bugs with new thread renaming SEO system?

    It works! Thanks MMan!

  11. #11

    • Pilot EdForceOne
    • Offline

    Join Date
    Jun 2006
    Posts
    15,667

    Re: Bugs with new thread renaming SEO system?

    Quote Originally Posted by Monorail Man View Post
    Try it now. I've tweaked a setting.

    It's worked for me in FF and IE and Safari.

    The Search Results have been fixed.
    Thread titles in 'find posts' - fixed!
    post links in 'find posts' - fixed!

    Ironically the link in your post in this thread doesn't work, but checking against your profile and mine and all links worked as should in FF 2.0

    Rockin - Thx MM - this is a huge implementation along with all the styles - you rock.
    Check out my blog - Coreplex: Rambling from inside the Grid


    Am I evil? yes, I am
    Am I evil? I am man, yes, I am

    Quote Originally Posted by sleepyjeff View Post
    Disneyland was meant to be sipped not chug-a-lugged

Similar Threads

  1. Problems with thread marking system
    By flynnibus in forum The Forums
    Replies: 3
    Last Post: 03-23-2009, 11:11 AM
  2. What's in a name? (Renaming DCA)
    By Uncle Bob in forum Disneyland Resort
    Replies: 47
    Last Post: 03-12-2008, 01:07 PM
  3. RCMC: The Emergency Thread System Has Been Activated
    By Ride Warrior in forum Fun and Games
    Replies: 2012
    Last Post: 02-16-2007, 11:45 PM
  4. Renaming a link???
    By Malibu Minion in forum The Tech Lounge
    Replies: 3
    Last Post: 01-26-2005, 08:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •