Results 1 to 3 of 3
  1. #1

    • Ravenclaw
    • Offline

    Join Date
    Mar 2007
    Location
    San Diego, California, United States
    Posts
    795

    iPhone 4S issues

    I just bought my first 4S. It's an Apple unlocked version, but I can't get the SIM card I bought here in Brazil (through Claro) to work. Every time I insert the SIM the phone searches for about 3 minutes and then says, "no signal":

    Using my co-workers' SIM cards (both Brazilian through Claro/Vivo/Tim and international through Vodafone, Orange, and Rogers) work fine in my phone.

    My SIM card works fine in my co-workers' phones.

    I'm not getting any "bad SIM', "SIM card failure", "invalid SIM", or "no SIM" error messages. Matter of fact is I'm not getting any error messages at all.

    Has anyone else experienced this?
    Amnesia used to be my favourite word, but I forgot it.

  2. #2

    • Just this guy......
    • Offline

    Join Date
    Jan 2005
    Location
    Los Angeles
    Posts
    2,532

    Re: iPhone 4S issues

    I can't help you, but I ran across this and it made me laugh.


  3. #3

    • Sock Puppet
    • Offline

    Join Date
    Jan 2012
    Posts
    8

    Re: iPhone 4S issues

    Quote Originally Posted by Exprmnt626 View Post
    I just bought my first 4S. It's an Apple unlocked version, but I can't get the SIM card I bought here in Brazil (through Claro) to work. Every time I insert the SIM the phone searches for about 3 minutes and then says, "no signal":

    Using my co-workers' SIM cards (both Brazilian through Claro/Vivo/Tim and international through Vodafone, Orange, and Rogers) work fine in my phone.

    My SIM card works fine in my co-workers' phones.

    I'm not getting any "bad SIM', "SIM card failure", "invalid SIM", or "no SIM" error messages. Matter of fact is I'm not getting any error messages at all.

    Has anyone else experienced this?
    maybe it is time to buy an android

Similar Threads

  1. The iPhone Issues/Resolutions thread
    By Soulquarian in forum The Tech Lounge
    Replies: 2
    Last Post: 07-03-2007, 02:36 PM
  2. Disney Copyright Issues
    By Lance in forum MiceChat News Archive
    Replies: 8
    Last Post: 05-19-2005, 05:03 PM
  3. Hunchback Issues
    By quasimodo1384 in forum MiceChat News Archive
    Replies: 36
    Last Post: 03-16-2005, 12:53 PM
  4. Language Issues
    By Malin in forum Tokyo Disney Resort
    Replies: 11
    Last Post: 02-09-2005, 04:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •